Uses of Interface
org.apache.juneau.marshall.stream.TokenWritable
Packages that use TokenWritable
Package
Description
CBOR (Concise Binary Object Representation) marshalling support per RFC 8949.
JCS (JSON Canonicalization Scheme) Marshalling Support.
JSON Marshalling Support.
JSON5 Marshalling Support.
JSON5L (JSON5 Lines) marshalling support.
JSONL (JSON Lines) marshalling support.
MessagePack Marshalling Support
-
Uses of TokenWritable in org.apache.juneau.marshall.cbor
Classes in org.apache.juneau.marshall.cbor that implement TokenWritableModifier and TypeClassDescriptionclassSerializes POJO models to CBOR (RFC 8949).static classDefault serializer, BASE64 string output.static classDefault serializer, spaced-hex string output.classSession object that lives for the duration of a single use ofCborSerializer. -
Uses of TokenWritable in org.apache.juneau.marshall.jcs
Classes in org.apache.juneau.marshall.jcs that implement TokenWritableModifier and TypeClassDescriptionclassSerializes POJO models to canonical JSON per RFC 8785 (JCS).classSession object forJcsSerializerthat produces RFC 8785 canonical JSON. -
Uses of TokenWritable in org.apache.juneau.marshall.json
Classes in org.apache.juneau.marshall.json that implement TokenWritableModifier and TypeClassDescriptionclassSerializes POJO metadata to HTTP responses as JSON-Schema.static classDefault serializer, with whitespace.classSession object that lives for the duration of a single use ofJsonSchemaSerializer.classSerializes POJO models to RFC 8259 JSON.static classDefault serializer, with whitespace.classSession object that lives for the duration of a single use ofJsonSerializer. -
Uses of TokenWritable in org.apache.juneau.marshall.json5
Classes in org.apache.juneau.marshall.json5 that implement TokenWritableModifier and TypeClassDescriptionclassSerializes POJO models to Simplified JSON.static classDefault serializer, single quotes, simple mode, with whitespace.classSession object that lives for the duration of a single use ofJson5Serializer. -
Uses of TokenWritable in org.apache.juneau.marshall.json5l
Classes in org.apache.juneau.marshall.json5l that implement TokenWritableModifier and TypeClassDescriptionclassSerializes POJO models to JSON5L (JSON5 Lines).classSession object that lives for the duration of a single use ofJson5lSerializer. -
Uses of TokenWritable in org.apache.juneau.marshall.jsonl
Classes in org.apache.juneau.marshall.jsonl that implement TokenWritableModifier and TypeClassDescriptionclassSerializes POJO models to JSONL (JSON Lines).classSession object that lives for the duration of a single use ofJsonlSerializer. -
Uses of TokenWritable in org.apache.juneau.marshall.msgpack
Classes in org.apache.juneau.marshall.msgpack that implement TokenWritableModifier and TypeClassDescriptionclassSerializes POJO models to MessagePack.static classDefault serializer, BASE64 string output.static classDefault serializer, spaced-hex string output.classSession object that lives for the duration of a single use ofMsgPackSerializer.